Icy Box NAS und Firmware-Update: Licht und Schatten


Ich hatte ja bereits von meinem RAID-Problem auf unserer Icy Box IB-NAS 4220 erzählt.

Kurz gesagt stellte sich das ganz so dar: alles schien zu funktionieren, aber die Web-Oberfläche meinte stets, es sei am Wiederhesrstellen des RAIDs, und behauptete sogar, einer der Platten sei unmounted. Gleichzeitig gab es aber im SMART-Protokoll keine Fehler, die auf einen Ausfall von Sektoren oder ähnliches hinwies.

Nach einiger Recherche im Netz stiess ich auf Berichte, die auf ein Problem mit neuerer Firmware hindeuteten, das irgendwie mit Partitionsgrößen zu tun hatte. Es gab also nur wenige Alternativen:

  • Box wegschmeissen und durch einen richtigen Server ersetzen, denn mit ähnlichen NAS-Geräten habe ich nicht vor, nochmal herumzuprobieren. Ich habe im Zuge dieser Geschichte beschlossen, nur noch Geräte zu nutzen, an die ich einen Monitor anstöpseln kann, und der ich beim Booten zuschauen kann. Wenn mal der SSH-Server auf der Bos aussetzt, steht man im Wald.
  • Box auf alte Firmware zurücksetzen, was mir nicht so recht gefallen mochte, denn ich hatte Probleme mit dem Spindown meiner WD-Platten. Sie legen sich mit der alten Firmware nicht schlafen, und so muss die Box immer ausgeschaltet werden, um das grüne Gewissen zu schonen
  • Box auf Firmwarestand lassen und RAID neu einrichten und wieder aus einem Backup bestücken
  • Box auf neueste Firmware aktuelisieren

Die letzten beiden waren mein Favorit.

Der erste Versuch war also, erstmal ein zusätzliches Backup zu ziehen. Da bei unserer Box der Backup-Knopf am Gerät nicht funktioniert, und ich ausserdem sicher gehen wollte, dass ich mit unseren Büromaschinen auf das Backup zugreifen kann (wir haben derzeit keinen physischen Linux-Rechner am Start), zog ich die Daten über einfaches Dateikopieren über den Mac auf eine USB-Platte und machte zugleich einen neuen Sync auf einen zweiten mac (Chronosync ist wirklich eine tolle Synchronisierungssoftware, mal so nebenbei bemerkt).

Zwei parallele Backups waren irgendwie zuviel, die Box lief nach ca. 1 Stunde Amok und legte das Netzwerk lahm. Es ging gar nichts mehr, kein Internetzugang, kein Zugriff auf Netzdrucker oder der Rechner untereinander, das komplette Netzt schien ausgefallen zu sein. Bis ich die Box ausgeschaltet habe. Die Lan-LED an der Box und am Switch blinkten wie die Hölle, wohl weil irgendwelche Zombie-Pakete im Umlauf waren.

Glücklicherweise konnte ich nach dem Neustart der Box und des Switches ein Backup ziehen und synchronisieren, ohen weitere Probleme.

Dann der Schock: ein Zugriff auf die Box per SSH war nicht mehr möglich: Connection Refused. Das Web Interface lief noch, Daten von der Box lesen und schreiben auch.

An den User-Konten lag es nicht, und der Dienst schien zu laufen, soweit dies dem Adminsitrationslog anzusehen war. Auf irgendwas nachgucken ging ja leider nicht, denn ich kam nur per Webinterface drauf.

Also: Letzte Hoffnung Factory Reset. Danach waren die Daten noch drauf, der Spindown der Platten ging leider nicht, weil die alte Firmware ja noch Fehler hatte. Aber leider war ja nun eine der beiden Platten mit einer größeren Systempartition ausgestattet, als die andere, und das RAID war demnach nach wie vor noch am ständigen Wiederherstellen.

Im Internet gibts zwar einige Tipps dazu, wie man die Partitionierung von Hand ändern kann, aber ich wollte mich da auf keine Abenteuer einlassen, meine Zeit ist mir zu kostbar für Experimente.

Da nen also sowieso partitoniert und restored werden musste, lag es nahe, gleich mal nach neuer Formware zu schauen. Die neueste mag Raidsonic ja nur auf Anfrage rausrücken (ist mir meine Zeit auch zu schade dafür), also habe ich einen Link auf eine fast ganz aktuelle Firmware gefunden.

Nun habe ich also die Firmware IB-NAS4220-2.6.3.2-20090424 drauf, das RAID neu eingerichtet und die Daten zurückgespielt.

Es scheint erstmal alles zu laufen, das Web Interface bietet nun mehr Optionen und vir allem scheint das RAID okay zu sein.

Leider funktioniert der Spindown nicht. Die Platten rotieren auch die ganze Nacht lang, wenn alle Rechner aus sind.

Dabei sind Schmakazien wie Twonky Media etc. deaktiviert. Aber der crond läuft doppelt, wahrscheinlich hat Raidsonic die ganze Kiste einfach nicht im Griff.

Also wir der Server nun zunächst immer schön ausgeschaltet, wenn er nicht gebraucht wird, und wir freuen uns erstmal daran, dass die Daten wieder auf 2 Platten gespiegelt sind. Immerhin das geht ja nun anscheinend.

Aber irgendwie wird’s wohl doch mit der Zeit wieder eine echte Linux-Kiste werden. Es gilt wohl doch: trau keinem, dem Du nicht beim Booten auf die Finger schauen kannst…